quopri — Encode and decode MIME quoted-printable data

Вихідний код: Lib/quopri.py


Цей модуль виконує транспортне кодування та декодування з можливістю друку в лапках, як визначено в RFC 1521: «MIME (багатоцільові розширення Інтернет-пошти) Частина перша: Механізми визначення та опису формату тіл Інтернет-повідомлень». Кодування для друку в лапках призначене для даних, де є відносно мало недрукованих символів; схема кодування base64, доступна через модуль base64, є більш компактною, якщо таких символів багато, наприклад, під час надсилання графічного файлу.

quopri.decode(input, output, header=False, *, strip_ws=False)

Decode the contents of the input file and write the resulting decoded binary data to the output file. input and output must be binary file objects. If the optional argument header is present and true, underscore will be decoded as space. This is used to decode «Q»-encoded headers as described in RFC 1522: «MIME (Multipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text». If the optional argument strip_ws is true, trailing whitespace is stripped from each line, as required by RFC 2045.

Змінено в версії 3.16.0a1 (unreleased): Added the strip_ws parameter.

quopri.encode(input, output, quotetabs, header=False)

Закодуйте вміст вхідного файлу та запишіть отримані цитовані дані для друку у вихідний файл. вхід і вихід мають бути бінарними файловими об’єктами. quotetabs, необов’язковий прапорець, який контролює, чи потрібно кодувати вбудовані пробіли та табуляції; коли true, він кодує такі вбудовані пробіли, а коли false, залишає їх незакодованими. Зверніть увагу, що пробіли та табуляції в кінці рядків завжди кодуються відповідно до RFC 1521. header — це позначка, яка контролює, чи кодуються пробіли як підкреслення відповідно до RFC 1522.

quopri.decodestring(s, header=False, *, strip_ws=False)

Подібно до decode(), за винятком того, що він приймає вихідні bytes і повертає відповідні декодовані bytes.

Змінено в версії 3.16.0a1 (unreleased): Added the strip_ws parameter.

quopri.encodestring(s, quotetabs=False, header=False)

Подібно до encode(), за винятком того, що він приймає вихідні bytes і повертає відповідні закодовані bytes. За замовчуванням він надсилає значення False до параметра quotetabs функції encode().

Дивись також

Модуль base64

Кодування та декодування даних MIME base64