quopri — Codifica e decodifica dados MIME imprimidos entre aspas¶
Código-fonte: Lib/quopri.py
Este módulo realiza codificação e decodificação de transporte imprimida entre aspas, como definido em RFC 1521: “MIME (Multipurpose Internet Mail Extensions) Part One: Mechanisms for Specifying and Describing the Format of Internet Message Bodies”. A codificação imprimida entre aspas é projetada para dados em que há relativamente poucos caracteres não imprimíveis; o esquema de codificação base64 disponível através do módulo base64 é mais compacto se existirem muitos desses caracteres, como no envio de um arquivo gráfico.
- quopri.decode(input, output, header=False, *, strip_ws=False)¶
Decode the contents of the input file and write the resulting decoded binary data to the output file. input and output must be binary file objects. If the optional argument header is present and true, underscore will be decoded as space. This is used to decode “Q”-encoded headers as described in RFC 1522: “MIME (Multipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text”. If the optional argument strip_ws is true, trailing whitespace is stripped from each line, as required by RFC 2045.
Alterado na versão 3.16.0a1 (unreleased): Added the strip_ws parameter.
- quopri.encode(input, output, quotetabs, header=False)¶
Codifica o conteúdo do arquivo input e grava os dados imprimíveis entre aspas resultantes no arquivo output. input e output devem ser objetos arquivos binários. quotetabs, um sinalizador não opcional que controla a codificação de espaços e tabulações incorporados; quando true, codifica esses espaços em branco incorporados e, quando false, os deixa sem codificação. Observe que os espaços e tabulações que aparecem no final das linhas são sempre codificados, conforme RFC 1521. header é um sinalizador que controla se os espaços são codificados como sublinhados, conforme RFC 1522.
- quopri.decodestring(s, header=False, *, strip_ws=False)¶
Como
decode(), exceto pelo fato de aceitar uma fontebytese retornar o correspondente decodificadobytes.Alterado na versão 3.16.0a1 (unreleased): Added the strip_ws parameter.
- quopri.encodestring(s, quotetabs=False, header=False)¶
Como
encode(), exceto pelo fato de aceitar uma fontebytese retornar obytescodificado correspondente. Por padrão, envia um valorFalsepara o parâmetro quotetabs da funçãoencode().
Ver também
- Módulo
base64 Codifica e decodifica dados de base64 MIME